summary refs log tree commit diff stats
path: root/system/modules/gaming.nix
diff options
context:
space:
mode:
authorAlan Pearce2019-10-02 16:55:35 +0200
committerAlan Pearce2019-10-02 16:55:35 +0200
commit340b2c244c0b7c331f6633edf9a69f1381916ad2 (patch)
tree2f430f20fbe01191c6b4a455bf792facef3f4fe7 /system/modules/gaming.nix
parentec7f1357d16ff2f4aa7430a2940a0b9519018595 (diff)
parent5016c7440ad771fd990e1aa142fc4de0bdc382bd (diff)
downloadnixfiles-340b2c244c0b7c331f6633edf9a69f1381916ad2.tar.lz
nixfiles-340b2c244c0b7c331f6633edf9a69f1381916ad2.tar.zst
nixfiles-340b2c244c0b7c331f6633edf9a69f1381916ad2.zip
Add 'system/' from commit '5016c7440ad771fd990e1aa142fc4de0bdc382bd'
git-subtree-dir: system
git-subtree-mainline: ec7f1357d16ff2f4aa7430a2940a0b9519018595
git-subtree-split: 5016c7440ad771fd990e1aa142fc4de0bdc382bd
Diffstat (limited to 'system/modules/gaming.nix')
-rw-r--r--system/modules/gaming.nix67
1 files changed, 67 insertions, 0 deletions
diff --git a/system/modules/gaming.nix b/system/modules/gaming.nix
new file mode 100644
index 00000000..44b937a8
--- /dev/null
+++ b/system/modules/gaming.nix
@@ -0,0 +1,67 @@
+{ config, pkgs, ... }:
+
+{ environment.systemPackages = with pkgs; [
+    unstable.steam
+    (
+      unstable.winePackages.unstable.override {
+        pngSupport = true;
+        jpegSupport = true;
+        tiffSupport = true;
+        gettextSupport = true;
+        fontconfigSupport = true;
+        alsaSupport = true;
+        gtkSupport = true;
+        openglSupport = true;
+        tlsSupport = true;
+        gstreamerSupport = true;
+        cupsSupport = true;
+        colorManagementSupport = true;
+        dbusSupport = true;
+        mpg123Support = true;
+        openalSupport = true;
+        openclSupport = true;
+        cairoSupport = true;
+        odbcSupport = true;
+        netapiSupport = true;
+        cursesSupport = true;
+        vaSupport = true;
+        pcapSupport = true;
+        v4lSupport = true;
+        saneSupport = true;
+        gsmSupport = true;
+        gphoto2Support = true;
+        ldapSupport = true;
+        pulseaudioSupport = true;
+        udevSupport = true;
+        xineramaSupport = true;
+        xmlSupport = true;
+        vulkanSupport = true;
+        sdlSupport = true;
+      }
+    )
+    unstable.lutris
+  ];
+  hardware.steam-hardware.enable = true;
+  hardware.opengl.driSupport32Bit = true;
+  hardware.pulseaudio.support32Bit = true;
+
+  systemd = {
+    extraConfig = ''
+      DefaultLimitNOFILE=524288
+    '';
+    user.extraConfig = ''
+      DefaultLimitNOFILE=524288
+    '';
+  };
+
+  networking.firewall = {
+    allowedUDPPorts = [
+      27031
+      27036
+    ];
+    allowedTCPPorts = [
+      27036
+      27037
+    ];
+  };
+}