summary refs log tree commit diff stats
path: root/system/marvin.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-11-11 22:12:59 +0100
committerAlan Pearce2024-11-11 22:12:59 +0100
commitcc7973d4c118f6322c78336c0ec9eda91d247195 (patch)
treeb3b61129cff5a840538a5ac6d877d7face34ca37 /system/marvin.nix
parentb70a1426322f6a0347e40d78fa3a7976f419f6fa (diff)
downloadnixfiles-cc7973d4c118f6322c78336c0ec9eda91d247195.tar.lz
nixfiles-cc7973d4c118f6322c78336c0ec9eda91d247195.tar.zst
nixfiles-cc7973d4c118f6322c78336c0ec9eda91d247195.zip
replace mba with marvin
Diffstat (limited to 'system/marvin.nix')
-rw-r--r--system/marvin.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/system/marvin.nix b/system/marvin.nix
new file mode 100644
index 00000000..68caa190
--- /dev/null
+++ b/system/marvin.nix
@@ -0,0 +1,40 @@
+{ ... }: {
+  imports = [
+    ./settings/darwin.nix
+    ./settings/dev.nix
+    ./settings/programs/shell.nix
+  ];
+
+  services.caddy = {
+    user = "root";
+    group = "wheel";
+  };
+
+  services.activate-system.enable = true;
+
+  environment.variables.LANG = "en_GB.UTF-8";
+
+  # Used for backwards compatibility, please read the changelog before changing.
+  # $ darwin-rebuild changelog
+  system.stateVersion = 4;
+
+  # You should generally set this to the total number of logical cores in your system.
+  # $ sysctl -n hw.ncpu
+  nix.settings = {
+    max-jobs = 8;
+    cores = 4;
+    auto-optimise-store = false; # https://github.com/NixOS/nix/issues/7273
+  };
+
+  nix.buildMachines = [
+    {
+      protocol = "ssh-ng";
+      sshUser = "nixremote";
+      hostName = "linde.alanpearce.eu";
+      system = "aarch64-linux";
+      maxJobs = 2;
+      speedFactor = 1;
+      supportedFeatures = [ ];
+    }
+  ];
+}