summary refs log tree commit diff stats
path: root/system/linde.nix
diff options
context:
space:
mode:
authorAlan Pearce2025-03-02 15:18:43 +0100
committerAlan Pearce2025-03-02 23:56:41 +0100
commitb5bcdf72cbc998550bf55af1842fe65f8c9ef0bf (patch)
tree06d7f026a1d6a026aeb548cf7a920a437270d995 /system/linde.nix
parent734a3cebed8dd4be66a546179dbda890abc5a10d (diff)
downloadnixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.tar.lz
nixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.tar.zst
nixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.zip
Revert "Switch back to flakes"
This reverts commit c0384c43821474d28af1d9696ceb473a0d769292.
Diffstat (limited to 'system/linde.nix')
-rw-r--r--system/linde.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/system/linde.nix b/system/linde.nix
index 5bf67cda..596cac19 100644
--- a/system/linde.nix
+++ b/system/linde.nix
@@ -17,14 +17,21 @@ let
   net-gw6 = "fe80::1";
   domain = "alanpearce.eu";
   ts-domain = "hydra-pinecone.ts.net";
+  golink = (builtins.getFlake (toString <golink>)).nixosModules.default;
 in
 {
   imports =
     [
+      <personal/modules/nixos/laminar.nix>
+      <home-manager/nixos>
+      <agenix/modules/age.nix>
+      <searchix/nix/modules>
+      golink
       # Include the results of the hardware scan.
       ./linde-hardware.nix
 
       ./settings/configuration/nix-linux.nix
+      ./settings/pin.nix
       ./settings/services/git-server.nix
     ];
   age.secrets = {
@@ -290,6 +297,9 @@ in
       "ecdsa-sha2-nistp256 AAAAE2VjZHNhLXNoYTItbmlzdHAyNTYAAAAIbmlzdHAyNTYAAABBBJVREjPey2TOIPzfYJoG9yIR4Rui7tNJK2QIKa+pbgsyXg31hhPIw37LRRIic+l53mW8eahHxX3Y1IeTjcMw8IU= alan@secretive.marvin"
     ];
   };
+  home-manager = {
+    users.alan = import ../user/server.nix;
+  };
 
   users.users.nixremote = {
     shell = "/bin/sh";