summary refs log tree commit diff stats
path: root/system/linde.nix
diff options
context:
space:
mode:
authorAlan Pearce2025-02-06 17:49:14 +0100
committerAlan Pearce2025-02-06 17:49:14 +0100
commit7dbf62563b7694315040d628e91f5149b241566c (patch)
tree4139908cd19d09e54622dc325e74e896eeef1eee /system/linde.nix
parent4b7a0e362655d346572e89be23bc004bb99321cf (diff)
downloadnixfiles-7dbf62563b7694315040d628e91f5149b241566c.tar.lz
nixfiles-7dbf62563b7694315040d628e91f5149b241566c.tar.zst
nixfiles-7dbf62563b7694315040d628e91f5149b241566c.zip
linde: run test version of homestead/website
Diffstat (limited to 'system/linde.nix')
-rw-r--r--system/linde.nix39
1 files changed, 30 insertions, 9 deletions
diff --git a/system/linde.nix b/system/linde.nix
index e82236d0..4a5fa0e2 100644
--- a/system/linde.nix
+++ b/system/linde.nix
@@ -507,17 +507,16 @@ in
           # Needed for HTTP->HTTPS servers
         };
         "alanpearce.eu" = {
-          serverAliases = [ "www.alanpearce.eu" "test.alanpearce.eu" ];
+          serverAliases = [
+            "www.alanpearce.eu"
+            "alanpearce.uk"
+            "www.alanpearce.uk"
+            "aln.pe"
+            "test.alanpearce.eu"
+          ];
           useACMEHost = "alanpearce.eu";
           extraConfig = ''
-            encode zstd gzip
-            root * /srv/http/website/public
-            file_server
-            ${security-headers {}}
-            handle_errors {
-              rewrite * /404.html
-              file_server
-            }
+            reverse_proxy http://localhost:8080
           '';
         };
         "${hostname}.alanpearce.eu" = {
@@ -1015,6 +1014,28 @@ in
       default = [{ type = "insecureAcceptAnything"; }];
     };
   };
+  virtualisation.oci-containers = {
+    containers.website = {
+      image = "ko.local/server:latest";
+      ports = [
+        "8080:8080"
+        "8443:8443"
+      ];
+      volumes = [
+        "data:/data"
+      ];
+      environmentFiles = [
+        config.age.secrets.powerdns.path
+      ];
+      environment = {
+        SERVER_LISTEN_ADDRESS = "::";
+        SERVER_TLS = "false";
+        WEBSITE_SOURCE = "/data/website";
+        WEBSITE_DESTINATION = "/data/public";
+        WEBSITE_REMOTE_VCS_URL = "https://git.alanpearce.eu/website";
+      };
+    };
+  };
 
   fileSystems."/srv/transmission" = {
     device = "//u439959-sub4.your-storagebox.de/u439959-sub4";