summary refs log tree commit diff stats
path: root/system/linde.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-06-21 21:41:22 +0200
committerAlan Pearce2024-06-21 21:41:22 +0200
commit3fae7d35d9b32ab3c4f7293c418167a52aff8717 (patch)
tree6b59370541bb1b7cedc7d7013c62f7fb229e76f0 /system/linde.nix
parent9cb844bacd7aa1191bbdccc4332f94aaa36bd648 (diff)
downloadnixfiles-3fae7d35d9b32ab3c4f7293c418167a52aff8717.tar.lz
nixfiles-3fae7d35d9b32ab3c4f7293c418167a52aff8717.tar.zst
nixfiles-3fae7d35d9b32ab3c4f7293c418167a52aff8717.zip
linde: de-flake
Diffstat (limited to 'system/linde.nix')
-rw-r--r--system/linde.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/system/linde.nix b/system/linde.nix
index f255bc30..5af32281 100644
--- a/system/linde.nix
+++ b/system/linde.nix
@@ -16,10 +16,15 @@ let
   net-mask6 = "64";
   net-gw6 = "fe80::1";
   ts-domain = "hydra-pinecone.ts.net";
+  golink = (builtins.getFlake (toString <golink>)).nixosModules.default;
 in
 {
   imports =
     [
+      <home-manager/nixos>
+      <agenix/modules/age.nix>
+      <searchix/nix/modules>
+      golink
       # Include the results of the hardware scan.
       ./linde-hardware.nix
 
@@ -313,6 +318,9 @@ in
       "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAII8VIII+598QOBxi/52O1Kb19RdUdX0aZmS1/dNoyqc5 alan@hetzner.strongbox"
     ];
   };
+  home-manager = {
+    users.alan = import ../user/server.nix;
+  };
 
   users.users.nixremote = {
     shell = "/bin/sh";