summary refs log tree commit diff stats
path: root/sources.nix
diff options
context:
space:
mode:
authorAlan Pearce2025-03-02 15:18:43 +0100
committerAlan Pearce2025-03-02 23:56:41 +0100
commitb5bcdf72cbc998550bf55af1842fe65f8c9ef0bf (patch)
tree06d7f026a1d6a026aeb548cf7a920a437270d995 /sources.nix
parent734a3cebed8dd4be66a546179dbda890abc5a10d (diff)
downloadnixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.tar.lz
nixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.tar.zst
nixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.zip
Revert "Switch back to flakes"
This reverts commit c0384c43821474d28af1d9696ceb473a0d769292.
Diffstat (limited to 'sources.nix')
-rw-r--r--sources.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/sources.nix b/sources.nix
new file mode 100644
index 00000000..624ddfc7
--- /dev/null
+++ b/sources.nix
@@ -0,0 +1,20 @@
+let
+  sources = import ./npins;
+  pkgs = import sources.nixpkgs { };
+  config =
+    if pkgs.stdenv.isDarwin
+    then "darwin-config"
+    else "nixos-config";
+  inherit (import ./lib { inherit pkgs; }) mkNixPath fromSources;
+
+  allSources = {
+    personal = ./packages;
+    nixpkgs-overlays = ./overlays;
+    private = ./private;
+    ${config} = ./system/configuration.nix;
+  } // (fromSources sources);
+in
+{
+  sources = allSources;
+  nixPath = mkNixPath allSources;
+}