summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-10-31 16:49:01 +0100
committerAlan Pearce2024-11-02 13:39:34 +0100
commitc0384c43821474d28af1d9696ceb473a0d769292 (patch)
tree4fed9f5175f02d36e0e58c4e93469c3705b085de /shell.nix
parent365c0df92f6e8c59a0e0c38eabae1ba6f35d129d (diff)
downloadnixfiles-c0384c43821474d28af1d9696ceb473a0d769292.tar.lz
nixfiles-c0384c43821474d28af1d9696ceb473a0d769292.tar.zst
nixfiles-c0384c43821474d28af1d9696ceb473a0d769292.zip
Switch back to flakes HEAD main
This reverts commits:
- 66e56cb0e1c95202133733c0812b794171dc73c5.
- 3fae7d35d9b32ab3c4f7293c418167a52aff8717.
- 417a1ce6481adfc713d8d0d6ad03e211a3d0eb22.
- 6b4469a98d7b2d88a3442b1051174000538199f0.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index b7d05d66..00000000
--- a/shell.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-let
-  inherit (import ./sources.nix) nixPath sources;
-
-  pkgs = import sources.nixpkgs { };
-in
-pkgs.mkShell
-{
-
-  name = "nixfiles-shell";
-
-  buildInputs = with pkgs; [
-    npins
-    (pkgs.callPackage "${sources.agenix}/pkgs/agenix.nix" { })
-    (import sources.home-manager { inherit pkgs; }).home-manager
-  ];
-
-  shellHook = ''
-    export NIX_PATH="${builtins.concatStringsSep ":" nixPath}";
-  '';
-}