summary refs log tree commit diff stats
path: root/pin.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-04-10 18:50:02 +0200
committerAlan Pearce2024-04-10 18:50:02 +0200
commit2b09b74ba617346a0c9c932543e658837ef9e5d2 (patch)
tree980c05a0e50d8026a0884c6015b440c31ebb2c6f /pin.nix
parenta2534b9daab7d39d2eeb005f7648b74bc72a8520 (diff)
downloadnixfiles-2b09b74ba617346a0c9c932543e658837ef9e5d2.tar.lz
nixfiles-2b09b74ba617346a0c9c932543e658837ef9e5d2.tar.zst
nixfiles-2b09b74ba617346a0c9c932543e658837ef9e5d2.zip
nix: pin nixpkgs to flake input globally and per-user
Diffstat (limited to 'pin.nix')
-rw-r--r--pin.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/pin.nix b/pin.nix
new file mode 100644
index 00000000..ab7c8b3e
--- /dev/null
+++ b/pin.nix
@@ -0,0 +1,11 @@
+{ inputs, ... }:
+let
+  inherit (inputs) nixpkgs;
+in
+{
+  nix = {
+    registry = {
+      nixpkgs.flake = nixpkgs;
+    };
+  };
+}