summary refs log tree commit diff stats
path: root/modules/satoshipay.nix
diff options
context:
space:
mode:
authorAlan Pearce2018-09-30 19:19:08 +0200
committerAlan Pearce2018-09-30 19:19:08 +0200
commitc74a9e9fefee59a23759de6791b19771316691fc (patch)
tree43c60762f28a45175fe2fbb16b4cb6857a0e52bd /modules/satoshipay.nix
parent5f4723df19ab14b917b98677aa74d20aaf5a6557 (diff)
parenta114b12027fbd82484833a7a2ded35273de39e3b (diff)
downloadnixfiles-c74a9e9fefee59a23759de6791b19771316691fc.tar.lz
nixfiles-c74a9e9fefee59a23759de6791b19771316691fc.tar.zst
nixfiles-c74a9e9fefee59a23759de6791b19771316691fc.zip
Merge branch 'master' of https://git.alanpearce.eu/nixos-configuration
Diffstat (limited to 'modules/satoshipay.nix')
-rw-r--r--modules/satoshipay.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/modules/satoshipay.nix b/modules/satoshipay.nix
index bbde34e8..75a04078 100644
--- a/modules/satoshipay.nix
+++ b/modules/satoshipay.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, lib, ... }:
+{ config, pkgs, fetchurl, lib, ... }:
 
 { virtualisation = {
     docker = {
@@ -23,11 +23,13 @@
   nixpkgs.config.allowUnfree = true;
 
   environment.systemPackages = with pkgs; [
+    openssl
     google-chrome
     docker_compose
     meteor
     minikube
     mongodb-tools
+    s3cmd
     sops
     unstable.google-cloud-sdk
     unstable.kubernetes
@@ -41,6 +43,7 @@
   services.mongodb = {
     enable = true;
     replSetName = "rs0";
+    dbpath = "/tmp/mongodb";
   };
   systemd.services.mongodb.wantedBy = lib.mkForce  [];
   systemd.timers.mongodb = {
@@ -65,7 +68,13 @@
 
 
   services.printing.drivers = with pkgs; [
-    unstable.cups-toshiba-estudio
+    (cups-toshiba-estudio.overrideAttrs (oldAttrs: {
+      version = "7.89";
+      src = pkgs.fetchurl {
+        url = http://business.toshiba.com/downloads/KB/f1Ulds/15178/TOSHIBA_ColorMFP_CUPS.tar;
+        sha256 = "0qz4r7q55i0adf4fv3aqnfqgi2pz3jb1jixkqm9x6nk4vanyjf4r";
+      };
+    }))
   ];
 
   networking.domain = "satoshipay.io";