summary refs log tree commit diff stats
path: root/modules/laptop.nix
diff options
context:
space:
mode:
authorAlan Pearce2017-09-10 14:38:21 +0200
committerAlan Pearce2017-09-10 14:38:21 +0200
commit45fcfe8435222078c2153f22b3f32d8bafb94633 (patch)
treebf1fe6a4e91a85f61c005004d700d99e8045d348 /modules/laptop.nix
parentda93d42ee1b52155080fd5a46f33e96c7e8346d3 (diff)
downloadnixfiles-45fcfe8435222078c2153f22b3f32d8bafb94633.tar.lz
nixfiles-45fcfe8435222078c2153f22b3f32d8bafb94633.tar.zst
nixfiles-45fcfe8435222078c2153f22b3f32d8bafb94633.zip
x250: Use synaptics driver instead of libinput
Diffstat (limited to 'modules/laptop.nix')
-rw-r--r--modules/laptop.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/laptop.nix b/modules/laptop.nix
index 3d6894cc..f0c88e7d 100644
--- a/modules/laptop.nix
+++ b/modules/laptop.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, ... }:
+{ config, pkgs, lib, ... }:
 
 { boot.kernelModules = [ "coretemp" ];
   boot.extraModulePackages = with config.boot.kernelPackages; [
@@ -62,7 +62,7 @@
 
   services.xserver = {
     libinput = {
-      enable = true;
+      enable = lib.mkDefault true;
       naturalScrolling = true;
       disableWhileTyping = true;
     };