summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-08 03:32:31 +0200
committerAlan Pearce2022-10-08 03:32:31 +0200
commitfc975d16c41c4f92f3e3dde4a837be52051b4e77 (patch)
tree418abb1dcff6ac4d6b2282592dfdb587a9ad0463 /flake.nix
parentad252750a5f086a3fecceacc5a5eaff3d080ab9d (diff)
downloadnixfiles-fc975d16c41c4f92f3e3dde4a837be52051b4e77.tar.lz
nixfiles-fc975d16c41c4f92f3e3dde4a837be52051b4e77.tar.zst
nixfiles-fc975d16c41c4f92f3e3dde4a837be52051b4e77.zip
Port mba darwin configuration to flakes
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 2de8b6cf..92a31715 100644
--- a/flake.nix
+++ b/flake.nix
@@ -4,13 +4,20 @@
     nixos-unstable.url = github:NixOS/nixpkgs/nixos-unstable;
     nixpkgs-unstable.url = github:NixOS/nixpkgs;
     nixos-hardware.url = github:NixOS/nixos-hardware;
+    darwin.url = github:lnl7/nix-darwin/master;
+    darwin.inputs.nixpkgs.follows = "nixpkgs-unstable";
   };
 
-  outputs = { self, nixos-unstable, ... }@attrs: {
+  outputs = { self, darwin, nixos-unstable, ... }@attrs: {
     nixosConfigurations.prefect = nixos-unstable.lib.nixosSystem {
       system = "x86_64-linux";
       specialArgs = attrs;
       modules = [ ./system/prefect.nix ];
     };
+    darwinConfigurations.mba = darwin.lib.darwinSystem {
+      system = "x86_64-darwin"; # aarch64 is still failing on some compiler-rt derivation
+      specialArgs = attrs;
+      modules = [ ./system/mba.nix ];
+    };
   };
 }