summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-15 10:04:11 +0200
committerAlan Pearce2024-05-15 10:04:11 +0200
commitfb2bc6ceba885133f6b2bd5d4a8d06fddf26eb15 (patch)
treeaa43a33a37c9c399d810bb25541bdd6bab69b3dd /flake.nix
parentde11d30c536c52381101a07230794bb724dd1c87 (diff)
downloadnixfiles-fb2bc6ceba885133f6b2bd5d4a8d06fddf26eb15.tar.lz
nixfiles-fb2bc6ceba885133f6b2bd5d4a8d06fddf26eb15.tar.zst
nixfiles-fb2bc6ceba885133f6b2bd5d4a8d06fddf26eb15.zip
make it easier to avoid downgrading servers during deployment
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 491ae0ab..459d2202 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,6 +1,7 @@
 {
   inputs = {
     nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+    nixpkgs-small.url = "github:NixOS/nixpkgs/nixos-unstable-small";
     nixos-hardware.url = "github:NixOS/nixos-hardware";
     nix-index-database.url = "github:Mic92/nix-index-database";
     nix-index-database.inputs.nixpkgs.follows = "nixpkgs";
@@ -25,6 +26,7 @@
     { self
     , utils
     , nixpkgs
+    , nixpkgs-small
     , nixos-hardware
     , home-manager
     , darwin
@@ -74,7 +76,7 @@
           common-gpu-nvidia-nonprime
         ]);
       };
-      nixosConfigurations.nanopi = nixpkgs.lib.nixosSystem {
+      nixosConfigurations.nanopi = nixpkgs-small.lib.nixosSystem {
         system = utils.lib.system.aarch64-linux;
         specialArgs = { inherit inputs; };
         modules = [
@@ -82,7 +84,7 @@
           ./system/nanopi.nix
         ];
       };
-      nixosConfigurations.linde = nixpkgs.lib.nixosSystem {
+      nixosConfigurations.linde = nixpkgs-small.lib.nixosSystem {
         system = utils.lib.system.aarch64-linux;
         specialArgs = { inherit inputs; };
         modules = [