summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-07 22:45:00 +0200
committerAlan Pearce2022-10-08 01:36:11 +0200
commitba1fcdddc1eee9b740dfb6c5f931cb489dae66ee (patch)
tree1b276eaa9a511d87d667ae2b540bf701969d98d6 /flake.nix
parent9451fdc13c2af6b0ff74a045127d8f0d0caf06ba (diff)
downloadnixfiles-ba1fcdddc1eee9b740dfb6c5f931cb489dae66ee.tar.lz
nixfiles-ba1fcdddc1eee9b740dfb6c5f931cb489dae66ee.tar.zst
nixfiles-ba1fcdddc1eee9b740dfb6c5f931cb489dae66ee.zip
Update to NixOS unstable
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 1249f2a9..2de8b6cf 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,12 +1,13 @@
 {
   inputs = {
-    nixpkgs.url = github:NixOS/nixpkgs/nixos-22.05;
+    nixos.url = github:NixOS/nixpkgs/nixos-22.05;
+    nixos-unstable.url = github:NixOS/nixpkgs/nixos-unstable;
     nixpkgs-unstable.url = github:NixOS/nixpkgs;
     nixos-hardware.url = github:NixOS/nixos-hardware;
   };
 
-  outputs = { self, nixpkgs, ... }@attrs: {
-    nixosConfigurations.prefect = nixpkgs.lib.nixosSystem {
+  outputs = { self, nixos-unstable, ... }@attrs: {
+    nixosConfigurations.prefect = nixos-unstable.lib.nixosSystem {
       system = "x86_64-linux";
       specialArgs = attrs;
       modules = [ ./system/prefect.nix ];