summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-12 06:15:06 +0200
committerAlan Pearce2022-10-12 06:16:02 +0200
commit880f752dc8d2f8c2457ddabd64623a7f4ec5a717 (patch)
tree093d12a93f15c1ec30328389432d33e26b58a6e6 /flake.nix
parent79e99bb67f841d829dd1775c2d47008a15ba63e2 (diff)
downloadnixfiles-880f752dc8d2f8c2457ddabd64623a7f4ec5a717.tar.lz
nixfiles-880f752dc8d2f8c2457ddabd64623a7f4ec5a717.tar.zst
nixfiles-880f752dc8d2f8c2457ddabd64623a7f4ec5a717.zip
Add secrets to home-manager configuration
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 24620fcb..1e235810 100644
--- a/flake.nix
+++ b/flake.nix
@@ -7,9 +7,13 @@
     home-manager.url = github:nix-community/home-manager;
     home-manager.inputs.nixpkgs.follows = "nixpkgs";
     emacs-overlay.url = github:nix-community/emacs-overlay;
+    secrets = {
+      url = git+ssh://git.alanpearce.eu/nixfiles-private;
+      flake = false;
+    };
   };
 
-  outputs = { self, darwin, home-manager, nixpkgs, ... }@attrs:
+  outputs = { self, darwin, home-manager, nixpkgs, secrets, ... }@attrs:
   let
     darwinSystem =
       "x86_64-darwin"; # aarch64 is still failing on some compiler-rt derivation
@@ -27,7 +31,7 @@
     };
     homeConfigurations.mba = home-manager.lib.homeManagerConfiguration {
       pkgs = darwinPkgs;
-      modules = [ ./user/mba.nix ];
+      modules = [ ./user/mba.nix (secrets + "/default.nix") ];
     };
   };
 }