about summary refs log tree commit diff stats
path: root/.build.yml
diff options
context:
space:
mode:
Diffstat (limited to '.build.yml')
-rw-r--r--.build.yml13
1 files changed, 13 insertions, 0 deletions
diff --git a/.build.yml b/.build.yml
new file mode 100644
index 0000000..d203753
--- /dev/null
+++ b/.build.yml
@@ -0,0 +1,13 @@
+image: nixos/unstable
+sources:
+  - https://git.alanpearce.eu/nix-packages
+environment:
+  NIX_CONFIG: "experimental-features = nix-command flakes"
+repositories:
+  nixpkgs: https://nixos.org/channels/nixpkgs-unstable
+tasks:
+  - nixpkgs: |
+      nix-instantiate --eval -E '(import <nixpkgs> {}).lib.version'
+
+  - build: |
+      nix shell -f '<nixpkgs>' nix-build-uncached -c nix-build-uncached nix-packages/ci.nix -A cacheOutputs