about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-10 15:10:01 +0200
committerAlan Pearce2024-05-10 15:24:10 +0200
commitd75a137c0fa6498ca6e35a0f257634ea3df1bec6 (patch)
tree1f40b38343c7b3b3c9288026585ec5c0644bde0a /flake.nix
downloadnix-packages-d75a137c0fa6498ca6e35a0f257634ea3df1bec6.tar.lz
nix-packages-d75a137c0fa6498ca6e35a0f257634ea3df1bec6.tar.zst
nix-packages-d75a137c0fa6498ca6e35a0f257634ea3df1bec6.zip
initial commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..81a143f
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,22 @@
+{
+  description = "My personal NUR repository";
+  inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+  outputs = { self, nixpkgs }:
+    let
+      systems = [
+        "x86_64-linux"
+        "i686-linux"
+        "x86_64-darwin"
+        "aarch64-linux"
+        "armv6l-linux"
+        "armv7l-linux"
+      ];
+      forAllSystems = f: nixpkgs.lib.genAttrs systems (system: f system);
+    in
+    {
+      legacyPackages = forAllSystems (system: import ./default.nix {
+        pkgs = import nixpkgs { inherit system; };
+      });
+      packages = forAllSystems (system: nixpkgs.lib.filterAttrs (_: v: nixpkgs.lib.isDerivation v) self.legacyPackages.${system});
+    };
+}