about summary refs log tree commit diff stats
path: root/default.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-10 15:10:01 +0200
committerAlan Pearce2024-05-10 15:24:10 +0200
commitd75a137c0fa6498ca6e35a0f257634ea3df1bec6 (patch)
tree1f40b38343c7b3b3c9288026585ec5c0644bde0a /default.nix
downloadnix-packages-d75a137c0fa6498ca6e35a0f257634ea3df1bec6.tar.lz
nix-packages-d75a137c0fa6498ca6e35a0f257634ea3df1bec6.tar.zst
nix-packages-d75a137c0fa6498ca6e35a0f257634ea3df1bec6.zip
initial commit
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..3846c24
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,20 @@
+# This file describes your repository contents.
+# It should return a set of nix derivations
+# and optionally the special attributes `lib`, `modules` and `overlays`.
+# It should NOT import <nixpkgs>. Instead, you should take pkgs as an argument.
+# Having pkgs default to <nixpkgs> is fine though, and it lets you use short
+# commands such as:
+#     nix-build -A mypackage
+
+{ pkgs ? import <nixpkgs> { } }:
+
+{
+  # The `lib`, `modules`, and `overlays` names are special
+  lib = import ./lib { inherit pkgs; }; # functions
+  modules = import ./modules; # NixOS modules
+  overlays = import ./overlays; # nixpkgs overlays
+
+  example-package = pkgs.callPackage ./pkgs/example-package { };
+  # some-qt5-package = pkgs.libsForQt5.callPackage ./pkgs/some-qt5-package { };
+  # ...
+}