all repos — nix-packages @ d75a137c0fa6498ca6e35a0f257634ea3df1bec6

My personal collection of packages for nix

initial commit

Alan Pearce
commit

d75a137c0fa6498ca6e35a0f257634ea3df1bec6

1 file changed, 22 insertions(+), 0 deletions(-)

changed files
A flake.nix
@@ -0,0 +1,22 @@
+{ + description = "My personal NUR repository"; + inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; + outputs = { self, nixpkgs }: + let + systems = [ + "x86_64-linux" + "i686-linux" + "x86_64-darwin" + "aarch64-linux" + "armv6l-linux" + "armv7l-linux" + ]; + forAllSystems = f: nixpkgs.lib.genAttrs systems (system: f system); + in + { + legacyPackages = forAllSystems (system: import ./default.nix { + pkgs = import nixpkgs { inherit system; }; + }); + packages = forAllSystems (system: nixpkgs.lib.filterAttrs (_: v: nixpkgs.lib.isDerivation v) self.legacyPackages.${system}); + }; +}