all repos — nix-packages @ d75a137c0fa6498ca6e35a0f257634ea3df1bec6

My personal collection of packages for nix

initial commit

Alan Pearce
commit

d75a137c0fa6498ca6e35a0f257634ea3df1bec6

1 file changed, 20 insertions(+), 0 deletions(-)

changed files
A default.nix
@@ -0,0 +1,20 @@
+# This file describes your repository contents. +# It should return a set of nix derivations +# and optionally the special attributes `lib`, `modules` and `overlays`. +# It should NOT import <nixpkgs>. Instead, you should take pkgs as an argument. +# Having pkgs default to <nixpkgs> is fine though, and it lets you use short +# commands such as: +# nix-build -A mypackage + +{ pkgs ? import <nixpkgs> { } }: + +{ + # The `lib`, `modules`, and `overlays` names are special + lib = import ./lib { inherit pkgs; }; # functions + modules = import ./modules; # NixOS modules + overlays = import ./overlays; # nixpkgs overlays + + example-package = pkgs.callPackage ./pkgs/example-package { }; + # some-qt5-package = pkgs.libsForQt5.callPackage ./pkgs/some-qt5-package { }; + # ... +}