flake: add `all` output for easier pushing in CI
1 file changed, 18 insertions(+), 5 deletions(-)
jump to
M flake.nix → flake.nix
@@ -15,12 +15,25 @@ ]; forAllSystems = f: nixpkgs.lib.genAttrs systems (system: f system); in { - legacyPackages = forAllSystems (system: import ./default.nix { + legacyPackages = forAllSystems (system: (import ./default.nix { pkgs = import nixpkgs { inherit system; }; - }); + })); packages = forAllSystems (system: - nixpkgs.lib.filterAttrs - (_: v: nixpkgs.lib.isDerivation v) - self.legacyPackages.${system}); + let + pkgs = import nixpkgs { inherit system; }; + + lpkgs = nixpkgs.lib.filterAttrs + (_: v: nixpkgs.lib.isDerivation v) + self.legacyPackages.${system}; + + all = pkgs.symlinkJoin { + name = "all"; + paths = builtins.attrValues lpkgs; + }; + in + (lpkgs // { + inherit all; + default = all; + })); }; }