all repos — nix-packages @ a28ff3126cb089e25d1938ab320d6dfdc1a30cef

My personal collection of packages for nix

modules/laminar: support showing a reason in the web interface

Alan Pearce
commit

a28ff3126cb089e25d1938ab320d6dfdc1a30cef

parent

affbe9a165a939dc51b38f3f0214552c237b2e6e

1 file changed, 10 insertions(+), 0 deletions(-)

jump to
M modules/nixos/laminar.nixmodules/nixos/laminar.nix
@@ -69,6 +69,13 @@ default = name;
description = "Name of the timer."; }; + reason = mkOption { + type = with types; nullOr str; + example = "Nightly build"; + default = null; + description = "optional human-readable string that will be displayed in the web UI as the cause of the build."; + }; + startAt = mkOption { type = with types; either str (listOf str); default = "daily";
@@ -179,6 +186,9 @@ cfg.package
"/run/wrappers" ] ++ cfg.path; + environment = { + LAMINAR_REASON = job.reason; + }; serviceConfig = { User = cfg.user; Group = cfg.group;