about summary refs log tree commit diff stats
diff options
context:
space:
mode:
authorAlan Pearce2024-05-18 22:09:14 +0200
committerAlan Pearce2024-05-18 22:09:14 +0200
commit9be4cd775be6d3bc3244ec06d69ff42aa4c8d6d5 (patch)
treebdc459708dce5b0d71fd3b52b5c63523bba84cd0
parent0fc8df6abdd0fdbf8ec797bf3324af50aa140bb5 (diff)
downloadnix-packages-9be4cd775be6d3bc3244ec06d69ff42aa4c8d6d5.tar.lz
nix-packages-9be4cd775be6d3bc3244ec06d69ff42aa4c8d6d5.tar.zst
nix-packages-9be4cd775be6d3bc3244ec06d69ff42aa4c8d6d5.zip
ci: push to binary cache
-rw-r--r--.build.yml12
1 files changed, 11 insertions, 1 deletions
diff --git a/.build.yml b/.build.yml
index d203753..68a233e 100644
--- a/.build.yml
+++ b/.build.yml
@@ -1,8 +1,13 @@
 image: nixos/unstable
 sources:
   - https://git.alanpearce.eu/nix-packages
+secrets:
+  - 5a04c7f9-bba4-40ab-b54c-a2daae2989e8
 environment:
-  NIX_CONFIG: "experimental-features = nix-command flakes"
+  NIX_CONFIG: |
+    experimental-features = nix-command flakes
+    extra-substituters = https://binarycache.alanpearce.eu
+    extra-trusted-public-keys = binarycache.alanpearce.eu:ZwqO3XMuajPictjwih8OY2+RXnOKpjZEZFHJjGSxAI4=
 repositories:
   nixpkgs: https://nixos.org/channels/nixpkgs-unstable
 tasks:
@@ -11,3 +16,8 @@ tasks:
 
   - build: |
       nix shell -f '<nixpkgs>' nix-build-uncached -c nix-build-uncached nix-packages/ci.nix -A cacheOutputs
+
+  - push-cache: |
+      nix copy --substitute-on-destination \
+        --to ssh://nixremote@linde.alanpearce.eu \
+        .