about summary refs log tree commit diff stats
diff options
context:
space:
mode:
authorAlan Pearce2024-05-18 21:40:54 +0200
committerAlan Pearce2024-05-18 21:40:54 +0200
commit91aef1ca21557c3d44835a5ffe8503b0c71149c0 (patch)
tree717a5271e1cd547cdfa3f9d5b3130b1526df24e0
parent39c225651ab8a4a266f9d6fd120c744ebe9af444 (diff)
downloadnix-packages-91aef1ca21557c3d44835a5ffe8503b0c71149c0.tar.lz
nix-packages-91aef1ca21557c3d44835a5ffe8503b0c71149c0.tar.zst
nix-packages-91aef1ca21557c3d44835a5ffe8503b0c71149c0.zip
htmlformat: init at unstable-2023-11-08
-rw-r--r--pkgs/htmlformat/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/htmlformat/default.nix b/pkgs/htmlformat/default.nix
new file mode 100644
index 0000000..93195dd
--- /dev/null
+++ b/pkgs/htmlformat/default.nix
@@ -0,0 +1,30 @@
+{ lib
+, buildGoModule
+, fetchFromGitHub
+}:
+
+buildGoModule rec {
+  pname = "htmlformat";
+  version = "unstable-2023-11-08";
+
+  src = fetchFromGitHub {
+    owner = "a-h";
+    repo = "htmlformat";
+    rev = "5bd994fe268e4d505a9793143fa85414c7d50887";
+    hash = "sha256-YSl9GsXhc0L2oKGZLwwjUtpe5W6ra6kk74zvQdsDCMU=";
+    sha256 = "1i880gdl3vwcxwjajsxbdvjmxnjj4c62z6d1l3v44wz1qld7sab1";
+    # date = "2023-11-08T12:46:58+00:00";
+  };
+
+  vendorHash = "sha256-uVfh1pPhfj6AyQDqFd1EDWshuyDRvbMDZj3SN5tCS2w=";
+
+  ldflags = [ "-s" "-w" ];
+
+  meta = with lib; {
+    description = "Htmlformat";
+    homepage = "https://github.com/a-h/htmlformat";
+    license = licenses.mit;
+    maintainers = with maintainers; [ alanpearce ];
+    mainProgram = "htmlformat";
+  };
+}