about summary refs log tree commit diff stats
diff options
context:
space:
mode:
authorAlan Pearce2024-05-19 00:03:00 +0200
committerAlan Pearce2024-05-19 00:03:00 +0200
commit8dfa231be5a30221c36e0431f07bfadb3348a09b (patch)
tree322812a3fdc8933eaa55195a3d2f8646cc0ef0e4
parentf7d962f81c40f87f5102513c4af44a4b655e80b4 (diff)
downloadnix-packages-8dfa231be5a30221c36e0431f07bfadb3348a09b.tar.lz
nix-packages-8dfa231be5a30221c36e0431f07bfadb3348a09b.tar.zst
nix-packages-8dfa231be5a30221c36e0431f07bfadb3348a09b.zip
ci: simplify GitHub actions
-rw-r--r--.github/workflows/build.yml9
1 files changed, 1 insertions, 8 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
index d2ce79c..ce9df0f 100644
--- a/.github/workflows/build.yml
+++ b/.github/workflows/build.yml
@@ -6,10 +6,6 @@ on:
 
 jobs:
   tests:
-    strategy:
-      matrix:
-        nixPath:
-          - nixpkgs=channel:nixos-unstable
     runs-on: macos-latest
     steps:
       - name: Install SSH Key
@@ -25,9 +21,7 @@ jobs:
       - name: Install Nix
         uses: cachix/install-nix-action@v26
         with:
-          nix_path: "${{ matrix.nixPath }}"
-          extra_nix_config: |
-            experimental-features = nix-command flakes
+          nix_path: nixpkgs=channel:nixos-unstable
       - name: Check evaluation
         run: |
           nix-env -f . -qa \* --meta --xml \
@@ -43,4 +37,3 @@ jobs:
         run: nix shell -f '<nixpkgs>' nix-build-uncached -c nix-build-uncached ci.nix -A cacheOutputs
       - name: Populate binary cache
         run: nix copy --substitute-on-destination --to ssh://nixremote@linde.alanpearce.eu .
-