about summary refs log tree commit diff stats
diff options
context:
space:
mode:
authorAlan Pearce2024-05-10 15:24:13 +0200
committerAlan Pearce2024-05-10 15:24:13 +0200
commit1fcaaf7946ac4b107e058fb7e87cd26618a446c2 (patch)
tree422ca215437816f20d0c9eb3b81da8e7196bba0e
parentd75a137c0fa6498ca6e35a0f257634ea3df1bec6 (diff)
downloadnix-packages-1fcaaf7946ac4b107e058fb7e87cd26618a446c2.tar.lz
nix-packages-1fcaaf7946ac4b107e058fb7e87cd26618a446c2.tar.zst
nix-packages-1fcaaf7946ac4b107e058fb7e87cd26618a446c2.zip
prettier-plugin-go-template: init at 0.0.15
-rw-r--r--default.nix4
-rw-r--r--pkgs/prettier-plugin-go-template/default.nix23
2 files changed, 24 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index 3846c24..5faa6e6 100644
--- a/default.nix
+++ b/default.nix
@@ -14,7 +14,5 @@
   modules = import ./modules; # NixOS modules
   overlays = import ./overlays; # nixpkgs overlays
 
-  example-package = pkgs.callPackage ./pkgs/example-package { };
-  # some-qt5-package = pkgs.libsForQt5.callPackage ./pkgs/some-qt5-package { };
-  # ...
+  prettier-plugin-go-template = pkgs.callPackage ./pkgs/prettier-plugin-go-template { };
 }
diff --git a/pkgs/prettier-plugin-go-template/default.nix b/pkgs/prettier-plugin-go-template/default.nix
new file mode 100644
index 0000000..fdaea29
--- /dev/null
+++ b/pkgs/prettier-plugin-go-template/default.nix
@@ -0,0 +1,23 @@
+{ lib, buildNpmPackage, fetchFromGitHub }:
+
+buildNpmPackage rec {
+  pname = "prettier-plugin-go-template";
+  version = "0.0.15";
+
+  src = fetchFromGitHub {
+    owner = "NiklasPor";
+    repo = "prettier-plugin-go-template";
+    rev = "b7fe3eeeeeef69587cca96b85473882a7f52c1c7";
+    hash = "sha256-K+BuKzOV0dP67TJLIn6BpAorDesNVp0710AS8XE+RV4=";
+  };
+
+  npmDepsHash = "sha256-PpJnVZFRxpUHux2jIBDtyBS4qNo6IJY4kwTAq6stEVQ=";
+
+  npmPackFlags = [ "--ignore-scripts" ];
+
+  meta = with lib; {
+    description = "Fixes prettier formatting for go templates 🐹";
+    homepage = "https://github.com/NiklasPor/prettier-plugin-go-template";
+    license = licenses.mit;
+  };
+}