all repos — nix-packages @ 8805ae08522e2192363814067dd44530582b488a

My personal collection of packages for nix

add go-instrument

Alan Pearce
commit

8805ae08522e2192363814067dd44530582b488a

parent

bc4c8fb8ad92ca5770f0804499bdd1e1ba3bab9e

1 file changed, 29 insertions(+), 0 deletions(-)

changed files
A pkgs/go-instrument/default.nix
@@ -0,0 +1,29 @@
+{ + lib, + buildGoModule, + fetchFromGitHub, +}: + +buildGoModule rec { + pname = "go-instrument"; + version = "1.7.0"; + + src = fetchFromGitHub { + owner = "nikolaydubina"; + repo = "go-instrument"; + rev = "v${version}"; + hash = "sha256-0WoID8hYtAu4EJbEgvHtJtE5keq33aGDMjFU9B+MLh8="; + }; + + vendorHash = "sha256-dofJA3Xxf68r4nKv6ocAYgnvOZD8eeezkaXLOqlRI6k="; + + ldflags = [ "-s" "-w" ]; + + meta = { + description = "Automatically add Trace Spans to Go methods and functions"; + homepage = "https://github.com/nikolaydubina/go-instrument"; + license = lib.licenses.mit; + maintainers = with lib.maintainers; [ alanpearce ]; + mainProgram = "go-instrument"; + }; +}