prettier-plugin-go-template: init at 0.0.15
2 files changed, 24 insertions(+), 3 deletions(-)
M default.nix → default.nix
@@ -14,7 +14,5 @@ lib = import ./lib { inherit pkgs; }; # functions modules = import ./modules; # NixOS modules overlays = import ./overlays; # nixpkgs overlays - example-package = pkgs.callPackage ./pkgs/example-package { }; - # some-qt5-package = pkgs.libsForQt5.callPackage ./pkgs/some-qt5-package { }; - # ... + prettier-plugin-go-template = pkgs.callPackage ./pkgs/prettier-plugin-go-template { }; }
A pkgs/prettier-plugin-go-template/default.nix
@@ -0,0 +1,23 @@ +{ lib, buildNpmPackage, fetchFromGitHub }: + +buildNpmPackage rec { + pname = "prettier-plugin-go-template"; + version = "0.0.15"; + + src = fetchFromGitHub { + owner = "NiklasPor"; + repo = "prettier-plugin-go-template"; + rev = "b7fe3eeeeeef69587cca96b85473882a7f52c1c7"; + hash = "sha256-K+BuKzOV0dP67TJLIn6BpAorDesNVp0710AS8XE+RV4="; + }; + + npmDepsHash = "sha256-PpJnVZFRxpUHux2jIBDtyBS4qNo6IJY4kwTAq6stEVQ="; + + npmPackFlags = [ "--ignore-scripts" ]; + + meta = with lib; { + description = "Fixes prettier formatting for go templates 🐹"; + homepage = "https://github.com/NiklasPor/prettier-plugin-go-template"; + license = licenses.mit; + }; +}