all repos — nix-packages @ 1dee212b8732d6360b7d3823ca923ab6946e428d

My personal collection of packages for nix

vanity-imports: init at 0.0.12

Alan Pearce
commit

1dee212b8732d6360b7d3823ca923ab6946e428d

parent

1f22eb1d157275d40400c83b57fac4ad65ecb1a2

2 files changed, 29 insertions(+), 0 deletions(-)

jump to
M default.nixdefault.nix
@@ -21,4 +21,5 @@ inherit (pkgs.darwin.apple_sdk.frameworks) Cocoa;
}; emacs-unlimited-select = pkgs.callPackage ./pkgs/emacs-unlimited-select { }; goatcounter = pkgs.callPackage ./pkgs/goatcounter { }; + vanity-imports = pkgs.callPackage ./pkgs/vanity-imports { }; }
A pkgs/vanity-imports/default.nix
@@ -0,0 +1,28 @@
+{ lib +, buildGoModule +, fetchFromGitHub +}: + +buildGoModule rec { + pname = "vanity-imports"; + version = "0.0.12"; + + src = fetchFromGitHub { + owner = "mlcdf"; + repo = "vanity-imports"; + rev = "v${version}"; + hash = "sha256-4JoJL079hBkwWVvOTRbCM1WZhM7hPlKQ+HEAUr7fWP8="; + }; + + vendorHash = "sha256-w0LaXevbGm1xpHvKxxyubHCOVRN712UzLyOd+hVikKg="; + + ldflags = [ "-s" "-w" ]; + + meta = with lib; { + description = "Use a custom domain in your Go import path"; + homepage = "https://github.com/mlcdf/vanity-imports"; + license = licenses.mit; + maintainers = with maintainers; [ alanpearce ]; + mainProgram = "vanity-imports"; + }; +}