summary refs log tree commit diff stats
path: root/prefect.nix
diff options
context:
space:
mode:
Diffstat (limited to 'prefect.nix')
-rw-r--r--prefect.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/prefect.nix b/prefect.nix
new file mode 100644
index 0000000..1c786a7
--- /dev/null
+++ b/prefect.nix
@@ -0,0 +1,41 @@
+{ config, pkgs, ... }:
+
+{ imports = [
+    ./hardware-configuration.nix
+
+    ./modules/configuration/berlin.nix
+    ./modules/configuration/british-english.nix
+    ./modules/configuration/nix.nix
+    ./modules/configuration/user.nix
+    ./modules/development/base.nix
+    ./modules/development/javascript.nix
+    ./modules/development/lisp.nix
+    ./modules/hardware/adb.nix
+    ./modules/hardware/audio.nix
+    ./modules/hardware/bare-metal.nix
+    ./modules/user-interface.nix
+    ./modules/hardware/colemak.nix
+    ./modules/hardware/nitrokey.nix
+    ./modules/hardware/mouse.nix
+    ./modules/hardware/systemd-boot.nix
+    ./modules/hardware/nvidia-gpu.nix
+    ./modules/programs/accounting.nix
+    ./modules/programs/dotfiles.nix
+    ./modules/programs/i3.nix
+    ./modules/programs/infrastructure.nix
+    ./modules/programs/passwords.nix
+    ./modules/programs/shell.nix
+    ./modules/services/syncthing.nix
+  ];
+
+  environment.systemPackages = with pkgs; [
+    chromium
+  ];
+
+  networking = {
+    hostName = "prefect";
+    domain = "alanpearce.eu";
+  };
+
+  system.stateVersion = "17.09";
+}