summary refs log tree commit diff stats
path: root/modules/syncthing.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/syncthing.nix')
-rw-r--r--modules/syncthing.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/syncthing.nix b/modules/syncthing.nix
new file mode 100644
index 0000000..9c9b778
--- /dev/null
+++ b/modules/syncthing.nix
@@ -0,0 +1,11 @@
+{ config, pkgs, ... }:
+
+{ services.syncthing = {
+    enable = true;
+    user = "alan";
+    group = "users";
+    systemService = true;
+    useInotify = true;
+    dataDir = "/home/alan/.config/syncthing";
+  };
+}