summary refs log tree commit diff stats
path: root/modules/satoshipay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/satoshipay.nix')
-rw-r--r--modules/satoshipay.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/satoshipay.nix b/modules/satoshipay.nix
index d8787eb..36561b5 100644
--- a/modules/satoshipay.nix
+++ b/modules/satoshipay.nix
@@ -41,10 +41,26 @@
     replSetName = "rs0";
   };
   systemd.services.mongodb.wantedBy = lib.mkForce  [];
+  systemd.timers.mongodb = {
+    description = "Delayed startup of MongoDB";
+    wantedBy = [ "timers.target" ];
+    timerConfig = {
+      OnActiveSec = "1 min";
+    };
+  };
+
   services.redis = {
     enable = true;
   };
   systemd.services.redis.wantedBy = lib.mkForce [];
+  systemd.timers.redis = {
+    description = "Delayed startup of Redis";
+    wantedBy = [ "timers.target" ];
+    timerConfig = {
+      OnActiveSec = "1 min";
+    };
+  };
+
 
   services.printing.drivers = with pkgs; [
     cups-toshiba-estudio