summary refs log tree commit diff stats
path: root/modules/satoshipay.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/satoshipay.nix')
-rw-r--r--modules/satoshipay.nix22
1 files changed, 13 insertions, 9 deletions
diff --git a/modules/satoshipay.nix b/modules/satoshipay.nix
index 75a0407..5198cc1 100644
--- a/modules/satoshipay.nix
+++ b/modules/satoshipay.nix
@@ -12,12 +12,6 @@
         enable = true;
       };
     };
-
-    virtualbox = {
-      host = {
-        enable = true;
-      };
-    };
   };
 
   nixpkgs.config.allowUnfree = true;
@@ -26,16 +20,15 @@
     openssl
     google-chrome
     docker_compose
-    meteor
-    minikube
     mongodb-tools
     s3cmd
     sops
     unstable.google-cloud-sdk
     unstable.kubernetes
+    unstable.kubectx
     unstable.redis-desktop-manager
     unstable.kubernetes-helm
-    unstable.kompose
+    unstable.helmfile
     unstable.robo3t
     unstable.slack
   ];
@@ -53,6 +46,17 @@
       OnActiveSec = "1 min";
     };
   };
+  systemd.services.mongodb-init = {
+    description = "Init mongodb replicaset";
+    requires = [ "mongodb.service" ];
+    script = "${pkgs.mongodb}/bin/mongo --eval 'rs.initiate()'";
+  };
+  systemd.timers.mongodb-init = {
+    wantedBy = [ "timers.target" ];
+    timerConfig = {
+      OnActiveSec = "2 min";
+    };
+  };
 
   services.redis = {
     enable = true;