summary refs log tree commit diff stats
path: root/modules/hardware/trezor.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/trezor.nix')
-rw-r--r--modules/hardware/trezor.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/modules/hardware/trezor.nix b/modules/hardware/trezor.nix
index ad938e9..ff1f8e3 100644
--- a/modules/hardware/trezor.nix
+++ b/modules/hardware/trezor.nix
@@ -1,4 +1,14 @@
-{ config, pkgs, ... }:
+{ config, lib, pkgs, ... }:
 
 { services.trezord.enable = true;
+  environment.systemPackages = with pkgs; [
+    gnupg
+    pinentry
+    (python3.withPackages(ps: with ps; [ trezor_agent wheel ]))
+  ];
+  environment.variables.GNUPGHOME = "$HOME/.gnupg/trezor/";
+  programs.gnupg.agent = {
+    enable = lib.mkForce false;
+    enableSSHSupport = lib.mkForce false;
+  };
 }