summary refs log tree commit diff stats
path: root/modules/hardware/nitrokey.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/nitrokey.nix')
-rw-r--r--modules/hardware/nitrokey.nix35
1 files changed, 1 insertions, 34 deletions
diff --git a/modules/hardware/nitrokey.nix b/modules/hardware/nitrokey.nix
index 3837f6f..a77ce00 100644
--- a/modules/hardware/nitrokey.nix
+++ b/modules/hardware/nitrokey.nix
@@ -1,46 +1,13 @@
 { config, pkgs, lib, ... }:
 
-{ programs.ssh.startAgent = false;
-
-  programs.gnupg = {
-    agent = {
-      enable = true;
-      enableSSHSupport = true;
-    };
-    dirmngr.enable = true;
-  };
-
+{
   hardware.nitrokey = {
     enable = true;
   };
 
   services.pcscd.enable = true;
-  services.keybase.enable = true;
-  services.kbfs.enable = true;
-  environment.variables.NIX_SKIP_KEYBASE_CHECKS = "1";
-
-  services.tor = {
-    enable = true;
-    client = {
-      enable = true;
-      socksListenAddress = "9050 IPv6Traffic";
-    };
-    torsocks = {
-      enable = true;
-    };
-  };
-  systemd.services.tor.wantedBy = lib.mkForce [];
-  systemd.timers.tor = {
-    description = "Delayed startup of Tor";
-    wantedBy = [ "timers.target" ];
-    timerConfig = {
-      OnActiveSec = "1 min";
-    };
-  };
 
   environment.systemPackages = with pkgs; [
-    gnupg
     nitrokey-app
-    keybase-gui
   ];
 }