summary refs log tree commit diff stats
path: root/modules/hardware/laptop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/laptop.nix')
-rw-r--r--modules/hardware/laptop.nix28
1 files changed, 2 insertions, 26 deletions
diff --git a/modules/hardware/laptop.nix b/modules/hardware/laptop.nix
index a09b12d..3024dae 100644
--- a/modules/hardware/laptop.nix
+++ b/modules/hardware/laptop.nix
@@ -18,30 +18,10 @@
     disper
   ];
 
-  # powerManagement.resumeCommands = ''
-  #   AUTORANDR="autorandr -c"
-
-  #   detect_display()
-  #   {
-  #     for X in /tmp/.X11-unix/X*; do
-  #       D="''${X##/tmp/.X11-unix/X}"
-  #       user=$(who | awk -vD="$D" '$5 ~ "\\(:"D"\\)$" {print $1}')
-  #       if [ x"$user" != x"" ]; then
-  #         export DISPLAY=":$D"
-  #         /bin/su -c "''${AUTORANDR}" "$user"
-  #       fi
-  #     done
-  #   }
-
-  #   case "$1" in
-  #     thaw|resume)
-  #       detect_display
-  #       ;;
-  #   esac
-  # '';
-
   programs.light.enable = true;
 
+  services.autorandr.enable = true;
+
   services.logind.extraConfig = ''
     IdleAction=suspend
     IdleActionSec=600
@@ -56,10 +36,6 @@
     '';
   };
 
-  services.udev.extraRules = ''
-    # ACTION=="change", SUBSYSTEM=="drm", ENV{DISPLAY}=":0", ENV{XAUTHORITY}="/home/alan/.Xauthority", RUN+="${pkgs.autorandr}/bin/autorandr -c"
-  '';
-
   services.xserver = {
     libinput = {
       enable = lib.mkDefault true;