summary refs log tree commit diff stats
path: root/modules/hardware/intel-gpu.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/intel-gpu.nix')
-rw-r--r--modules/hardware/intel-gpu.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/hardware/intel-gpu.nix b/modules/hardware/intel-gpu.nix
new file mode 100644
index 0000000..b44ddad
--- /dev/null
+++ b/modules/hardware/intel-gpu.nix
@@ -0,0 +1,14 @@
+{ config, pkgs, ... }:
+
+{ hardware.opengl.extraPackages = with pkgs; [
+    vaapiIntel
+  ];
+
+  boot.earlyVconsoleSetup = true;
+  boot.initrd.kernelModules = [
+    "i915"
+  ];
+  boot.kernelModules = [
+    "i915"
+  ];
+}