summary refs log tree commit diff stats
path: root/modules/hardware/bare-metal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/bare-metal.nix')
-rw-r--r--modules/hardware/bare-metal.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/hardware/bare-metal.nix b/modules/hardware/bare-metal.nix
new file mode 100644
index 0000000..b5e0fc7
--- /dev/null
+++ b/modules/hardware/bare-metal.nix
@@ -0,0 +1,18 @@
+{ config, pkgs, ... }:
+
+{ environment.systemPackages = with pkgs; [
+    fuse_exfat
+    cryptsetup
+    dmidecode
+    hdparm
+    pciutils
+    usbutils
+  ];
+
+  boot.kernelPackages = pkgs.linuxPackages_4_12;
+
+  boot.tmpOnTmpfs = true;
+
+  fileSystems."/".options = [ "noatime" "nodiratime" ];
+  fileSystems."/home".options = [ "noatime" "nodiratime" ];
+}