summary refs log tree commit diff stats
path: root/marvin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'marvin.nix')
-rw-r--r--marvin.nix45
1 files changed, 23 insertions, 22 deletions
diff --git a/marvin.nix b/marvin.nix
index c3508fb..55a97fd 100644
--- a/marvin.nix
+++ b/marvin.nix
@@ -2,28 +2,29 @@
 
 { imports = [
     ./hardware-configuration.nix
-    ./modules/systemd-boot.nix
-    ./modules/audio.nix
-    ./modules/adb.nix
-    ./modules/syncthing.nix
-    ./modules/nitrokey.nix
-    ./modules/shell.nix
-    ./modules/dotfiles.nix
-    ./modules/berlin.nix
-    ./modules/colemak.nix
-    ./modules/trackball.nix
-    ./modules/british-english.nix
-    ./modules/x250.nix
-    ./modules/user.nix
-    ./modules/dev.nix
-    ./modules/lisp.nix
-    ./modules/javascript.nix
-    ./modules/infrastructure.nix
-    ./modules/accounting.nix
-    ./modules/passwords.nix
-    ./modules/network-manager.nix
-    ./modules/nix.nix 
-    ./modules/i3.nix
+
+    ./modules/configuration/berlin.nix
+    ./modules/configuration/british-english.nix
+    ./modules/configuration/nix.nix
+    ./modules/configuration/user.nix
+    ./modules/development/base.nix
+    ./modules/development/javascript.nix
+    ./modules/development/lisp.nix
+    ./modules/hardware/adb.nix
+    ./modules/hardware/audio.nix
+    ./modules/hardware/colemak.nix
+    ./modules/hardware/network-manager.nix
+    ./modules/hardware/nitrokey.nix
+    ./modules/hardware/systemd-boot.nix
+    ./modules/hardware/trackball.nix
+    ./modules/machines/x250.nix
+    ./modules/programs/accounting.nix
+    ./modules/programs/dotfiles.nix
+    ./modules/programs/i3.nix
+    ./modules/programs/infrastructure.nix
+    ./modules/programs/passwords.nix
+    ./modules/programs/shell.nix
+    ./modules/services/syncthing.nix
   ];
 
   environment.systemPackages = with pkgs; [