summary refs log tree commit diff stats
path: root/cachix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'cachix.nix')
-rw-r--r--cachix.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/cachix.nix b/cachix.nix
new file mode 100644
index 0000000..cce90a3
--- /dev/null
+++ b/cachix.nix
@@ -0,0 +1,14 @@
+
+# WARN: this file will get overwritten by $ cachix use <name>
+{ pkgs, lib, ... }:
+
+let
+  folder = ./cachix;
+  toImport = name: value: folder + ("/" + name);
+  filterCaches = key: value: value == "regular" && lib.hasSuffix ".nix" key;
+  imports = lib.mapAttrsToList toImport (lib.filterAttrs filterCaches (builtins.readDir folder));
+in {
+  inherit imports;
+  nix.binaryCaches = ["https://cache.nixos.org/"];
+}
+    
\ No newline at end of file