summary refs log tree commit diff stats
path: root/modules/synaptics.nix
diff options
context:
space:
mode:
authorAlan Pearce2017-09-10 14:38:21 +0200
committerAlan Pearce2017-09-10 14:38:21 +0200
commit45fcfe8435222078c2153f22b3f32d8bafb94633 (patch)
treebf1fe6a4e91a85f61c005004d700d99e8045d348 /modules/synaptics.nix
parentda93d42ee1b52155080fd5a46f33e96c7e8346d3 (diff)
downloadnixos-configuration-45fcfe8435222078c2153f22b3f32d8bafb94633.tar.lz
nixos-configuration-45fcfe8435222078c2153f22b3f32d8bafb94633.tar.zst
nixos-configuration-45fcfe8435222078c2153f22b3f32d8bafb94633.zip
x250: Use synaptics driver instead of libinput
Diffstat (limited to 'modules/synaptics.nix')
-rw-r--r--modules/synaptics.nix35
1 files changed, 19 insertions, 16 deletions
diff --git a/modules/synaptics.nix b/modules/synaptics.nix
index 0e9db17..1028db3 100644
--- a/modules/synaptics.nix
+++ b/modules/synaptics.nix
@@ -1,24 +1,27 @@
 { config, pkgs, ... }:
 
-{ services.xserver.synaptics = {
-    enable = true;
+{ services.xserver = {
+    libinput.enable = false;
+    synaptics = {
+      enable = true;
 
-    accelFactor = "0.001";
+      accelFactor = "0.05";
 
-    minSpeed = "0.4";
-    maxSpeed = "2.0";
+      minSpeed = "0.2";
+      maxSpeed = "1.0";
 
-    palmDetect = true;
-    palmMinWidth = 5;
-    palmMinZ = 20;
+      palmDetect = true;
+      palmMinWidth = 5;
+      palmMinZ = 20;
 
-    twoFingerScroll = true;
-    vertTwoFingerScroll = true;
-    horizTwoFingerScroll = true;
-    additionalOptions = ''
-      Option "RBCornerButton" "3"
-      Option "VertScrollDelta" "-111"
-      Option "HorizScrollDelta" "-111"
-    '';
+      twoFingerScroll = true;
+      vertTwoFingerScroll = true;
+      horizTwoFingerScroll = true;
+      additionalOptions = ''
+        Option "RBCornerButton" "3"
+        Option "VertScrollDelta" "-111"
+        Option "HorizScrollDelta" "-111"
+      '';
+    };
   };
 }