summary refs log tree commit diff stats
path: root/modules/programs/window-manager.nix
diff options
context:
space:
mode:
authorAlan Pearce2017-09-23 13:59:19 +0200
committerAlan Pearce2017-09-23 14:10:26 +0200
commit0f2c55992677e78d5d2908d0648e410ef9b27436 (patch)
treeb2a3432e15dd9af506c317af608ea69721979a41 /modules/programs/window-manager.nix
parent496b4ed379afe7f1e0563243a0a5efe0857fe3bb (diff)
downloadnixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.tar.lz
nixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.tar.zst
nixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.zip
Organise modules into folders
Diffstat (limited to 'modules/programs/window-manager.nix')
-rw-r--r--modules/programs/window-manager.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/programs/window-manager.nix b/modules/programs/window-manager.nix
new file mode 100644
index 0000000..c159374
--- /dev/null
+++ b/modules/programs/window-manager.nix
@@ -0,0 +1,18 @@
+{ config, pkgs, ... }:
+
+{ services.xserver.displayManager = {
+    lightdm = {
+      enable = true;
+    };
+  };
+
+  environment.systemPackages = with pkgs; [
+    dmenu
+    dunst
+    libnotify # for notify-send
+    sxhkd
+    scrot
+
+    perlPackages.FileMimeInfo # xdg-utils uses this when no DE
+  ];
+}