summary refs log tree commit diff stats
path: root/modules/programs/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2017-11-12 15:49:09 +0100
committerAlan Pearce2017-11-12 15:49:09 +0100
commit8e9beabee821f2fcaaaa7efb77f7709d837e4f45 (patch)
tree99a9da8635f0afbb15f8d98b7a0d22e7f4fe62e0 /modules/programs/shell.nix
parentb7f9088955ebbc58eeaef17f6036cb20b702371c (diff)
downloadnixos-configuration-8e9beabee821f2fcaaaa7efb77f7709d837e4f45.tar.lz
nixos-configuration-8e9beabee821f2fcaaaa7efb77f7709d837e4f45.tar.zst
nixos-configuration-8e9beabee821f2fcaaaa7efb77f7709d837e4f45.zip
shell: Add some "modern" utilities
Diffstat (limited to 'modules/programs/shell.nix')
-rw-r--r--modules/programs/shell.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/modules/programs/shell.nix b/modules/programs/shell.nix
index 54d54e3..dc85ccc 100644
--- a/modules/programs/shell.nix
+++ b/modules/programs/shell.nix
@@ -12,6 +12,9 @@
   environment.systemPackages = with pkgs; [
     vim
     pv
+    fd
+    entr
+    exa
     file
     htop
     lsof
@@ -26,5 +29,7 @@
     zip
     unzip
     telnet
+
+    haskellPackages.una
   ];
 }