summary refs log tree commit diff stats
path: root/modules/programs/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2017-09-23 13:59:19 +0200
committerAlan Pearce2017-09-23 14:10:26 +0200
commit0f2c55992677e78d5d2908d0648e410ef9b27436 (patch)
treeb2a3432e15dd9af506c317af608ea69721979a41 /modules/programs/shell.nix
parent496b4ed379afe7f1e0563243a0a5efe0857fe3bb (diff)
downloadnixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.tar.lz
nixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.tar.zst
nixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.zip
Organise modules into folders
Diffstat (limited to 'modules/programs/shell.nix')
-rw-r--r--modules/programs/shell.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/modules/programs/shell.nix b/modules/programs/shell.nix
new file mode 100644
index 0000000..3ea43ad
--- /dev/null
+++ b/modules/programs/shell.nix
@@ -0,0 +1,29 @@
+{ config, pkgs, ... }:
+
+{ programs.zsh = {
+    enable = true;
+    promptInit = "";
+  };
+  programs.bash.enableCompletion = true;
+  programs.xonsh = {
+    enable = true;
+  };
+
+  environment.systemPackages = with pkgs; [
+    vim
+    pv
+    file
+    htop
+    lsof
+    iftop
+    iotop
+    nmap
+    netperf
+    moreutils
+    psmisc
+    tree
+    zip
+    unzip
+    telnet
+  ];
+}