summary refs log tree commit diff stats
path: root/modules/programs/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2018-10-21 14:55:27 +0200
committerAlan Pearce2018-10-21 15:01:02 +0200
commit086e0f60c01730cacd716f14115bef99774f6957 (patch)
tree864771585e2c27878d63520d39589ff2c3740517 /modules/programs/shell.nix
parente30c6624e41d8b8b55085897a57f9c9c0c6c3edf (diff)
downloadnixos-configuration-086e0f60c01730cacd716f14115bef99774f6957.tar.lz
nixos-configuration-086e0f60c01730cacd716f14115bef99774f6957.tar.zst
nixos-configuration-086e0f60c01730cacd716f14115bef99774f6957.zip
Setup trillian (MacBook)
Diffstat (limited to 'modules/programs/shell.nix')
-rw-r--r--modules/programs/shell.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/modules/programs/shell.nix b/modules/programs/shell.nix
index b7bbd8f..d59f9fb 100644
--- a/modules/programs/shell.nix
+++ b/modules/programs/shell.nix
@@ -5,9 +5,9 @@
     promptInit = "";
   };
   programs.bash.enableCompletion = true;
+  programs.vim.enable = pkgs.stdenv.isDarwin;
 
   environment.systemPackages = with pkgs; [
-    vim
     pv
     fd
     entr
@@ -23,7 +23,11 @@
     zip
     unzip
     telnet
-
+  ] ++ (
+  if !stdenv.isDarwin
+  then [
+    vim
     unar
-  ];
+  ] else [
+  ]);
 }