summary refs log tree commit diff stats
path: root/modules/laptop.nix
diff options
context:
space:
mode:
authorAlan Pearce2017-09-23 13:59:19 +0200
committerAlan Pearce2017-09-23 14:10:26 +0200
commit0f2c55992677e78d5d2908d0648e410ef9b27436 (patch)
treeb2a3432e15dd9af506c317af608ea69721979a41 /modules/laptop.nix
parent496b4ed379afe7f1e0563243a0a5efe0857fe3bb (diff)
downloadnixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.tar.lz
nixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.tar.zst
nixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.zip
Organise modules into folders
Diffstat (limited to 'modules/laptop.nix')
-rw-r--r--modules/laptop.nix77
1 files changed, 0 insertions, 77 deletions
diff --git a/modules/laptop.nix b/modules/laptop.nix
deleted file mode 100644
index c50c28e..0000000
--- a/modules/laptop.nix
+++ /dev/null
@@ -1,77 +0,0 @@
-{ config, pkgs, lib, ... }:
-
-{ boot.kernelModules = [ "coretemp" ];
-  boot.extraModulePackages = with config.boot.kernelPackages; [
-    x86_energy_perf_policy
-  ];
-
-  hardware = {
-    bluetooth.enable = true;
-  };
-
-  environment.systemPackages = with pkgs; [
-    powerstat
-    powertop
-
-    arandr
-    autorandr
-    disper
-  ];
-
-  # powerManagement.resumeCommands = ''
-  #   AUTORANDR="autorandr -c"
-
-  #   detect_display()
-  #   {
-  #     for X in /tmp/.X11-unix/X*; do
-  #       D="''${X##/tmp/.X11-unix/X}"
-  #       user=$(who | awk -vD="$D" '$5 ~ "\\(:"D"\\)$" {print $1}')
-  #       if [ x"$user" != x"" ]; then
-  #         export DISPLAY=":$D"
-  #         /bin/su -c "''${AUTORANDR}" "$user"
-  #       fi
-  #     done
-  #   }
-
-  #   case "$1" in
-  #     thaw|resume)
-  #       detect_display
-  #       ;;
-  #   esac
-  # '';
-
-  programs.light.enable = true;
-
-  services.logind.extraConfig = ''
-    IdleAction=suspend
-    IdleActionSec=600
-  '';
-
-  services.physlock.enable = false;
-
-  services.tlp = {
-    enable = true;
-    extraConfig = ''
-      CPU_SCALING_GOVERNOR_ON_BAT=powersave
-    '';
-  };
-
-  services.udev.extraRules = ''
-    # ACTION=="change", SUBSYSTEM=="drm", ENV{DISPLAY}=":0", ENV{XAUTHORITY}="/home/alan/.Xauthority", RUN+="${pkgs.autorandr}/bin/autorandr -c"
-  '';
-
-  services.xserver = {
-    libinput = {
-      enable = lib.mkDefault true;
-      naturalScrolling = true;
-      disableWhileTyping = true;
-    };
-  };
-
-  systemd.services.nixos-upgrade.unitConfig.ConditionACPower = true;
-  systemd.services.nix-gc.unitConfig.ConditionACPower = true;
-
-  imports = [
-    ./user-interface.nix
-  ];
-}