summary refs log tree commit diff stats
path: root/modules/hardware/mouse.nix
diff options
context:
space:
mode:
authorAlan Pearce2017-10-22 19:38:21 +0200
committerAlan Pearce2017-10-22 19:38:21 +0200
commitee10aadfcfaf1aaf4e0394210ba0629920881406 (patch)
tree7c4b180cb4784fe26167a3b292ec1a95e60e6a7d /modules/hardware/mouse.nix
parent90267cf07027564be14043edf72bbe622efc76d8 (diff)
downloadnixos-configuration-ee10aadfcfaf1aaf4e0394210ba0629920881406.tar.lz
nixos-configuration-ee10aadfcfaf1aaf4e0394210ba0629920881406.tar.zst
nixos-configuration-ee10aadfcfaf1aaf4e0394210ba0629920881406.zip
Add base configuration for prefect
Diffstat (limited to 'modules/hardware/mouse.nix')
-rw-r--r--modules/hardware/mouse.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/modules/hardware/mouse.nix b/modules/hardware/mouse.nix
new file mode 100644
index 0000000..b30d412
--- /dev/null
+++ b/modules/hardware/mouse.nix
@@ -0,0 +1,12 @@
+{ config, pkgs, ... }:
+
+{ services.xserver.config = ''
+    Section "InputClass"
+        Identifier "Mouse (No Acceleration)"
+        MatchIsPointer "yes"
+        MatchIsTouchpad "no"
+        Option "AccelerationProfile" "-1"
+        Option "AccelerationScheme" "none"
+    EndSection
+  '';
+}