summary refs log tree commit diff stats
path: root/modules/hardware/connman.nix
diff options
context:
space:
mode:
authorAlan Pearce2017-09-23 13:59:19 +0200
committerAlan Pearce2017-09-23 14:10:26 +0200
commit0f2c55992677e78d5d2908d0648e410ef9b27436 (patch)
treeb2a3432e15dd9af506c317af608ea69721979a41 /modules/hardware/connman.nix
parent496b4ed379afe7f1e0563243a0a5efe0857fe3bb (diff)
downloadnixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.tar.lz
nixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.tar.zst
nixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.zip
Organise modules into folders
Diffstat (limited to 'modules/hardware/connman.nix')
-rw-r--r--modules/hardware/connman.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/modules/hardware/connman.nix b/modules/hardware/connman.nix
new file mode 100644
index 0000000..0361f9c
--- /dev/null
+++ b/modules/hardware/connman.nix
@@ -0,0 +1,14 @@
+{ config, pkgs, ... }:
+
+{ networking.connman = {
+    enable = true;
+    enableVPN = false;
+  };
+  networking.wireless.enable = true;
+
+  environment.systemPackages = with pkgs; [
+    cmst
+    connman-notify
+    connman_dmenu
+  ];
+}