about summary refs log tree commit diff stats
path: root/nix/modules/source-options.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/source-options.nix')
-rw-r--r--nix/modules/source-options.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/nix/modules/source-options.nix b/nix/modules/source-options.nix
index 4757c89..d60d023 100644
--- a/nix/modules/source-options.nix
+++ b/nix/modules/source-options.nix
@@ -1,9 +1,11 @@
-{ cfg }:
+{ cfg, settingsFormat }:
 { config, lib, name, ... }:
 let
   inherit (lib) literalExpression mkOption mkEnableOption types;
 in
 {
+  freeformType = settingsFormat.type;
+
   options = {
     key = mkOption {
       type = types.strMatching "[a-z0-9_-]*";