about summary refs log tree commit diff stats
path: root/nix/modules/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/default.nix')
-rw-r--r--nix/modules/default.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/nix/modules/default.nix b/nix/modules/default.nix
index 8c8499a..509a372 100644
--- a/nix/modules/default.nix
+++ b/nix/modules/default.nix
@@ -106,11 +106,15 @@ in
                   default = "localhost";
                 };
 
-                baseURL = mkOption {
-                  type = types.str;
-                  description = "The base URL that searchix will be served on.";
-                  default = "http://localhost:3000";
-                };
+                baseURL =
+                  let
+                    inherit (config.services.searchix.settings) web;
+                  in
+                  mkOption {
+                    type = types.str;
+                    description = "The base URL that searchix will be served on.";
+                    default = "http://${web.listenAddress}:${web.port}";
+                  };
 
                 environment = mkOption {
                   type = types.str;