about summary refs log tree commit diff stats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 10f7ac7..3de02f2 100644
--- a/default.nix
+++ b/default.nix
@@ -61,6 +61,14 @@ in
       yamllint = {
         enable = true;
       };
+      golines = {
+        enable = true;
+        name = "golines";
+        description = "A golang formatter that fixes long lines";
+        types_or = [ "go" ];
+        entry = "${pkgs.golines}/bin/golines --write-output";
+        pass_filenames = true;
+      };
       go-mod-tidy = {
         enable = true;
         name = "go-mod-tidy";